Sign in

Зарегистрируйтесь, чтобы стать полноправным участником сообщества Masterpro.ws.

Fedora. Building package from the Git Repository

purple-facebook

Возможно, быстрый этот мануал поможет тому, кто захочет установить тот или иной пакет из GitHub в свою настольную операционную систему Fedora; что до меня, устанавливал таким образом purple-facebook для pidgin (не хотелось ждать, пока обновленный пакет появится в оф. репах Fedora 25):

 

Fixes groupchat join errors
Send orca-formatted user agent for all HTTP requests too. Fixes "Failed to parse thread information" errors when joining channels.
This is in addition to the connection error fixes mentioned in the previous release that happened earlier today. Quoting from the previous release:
It fixes connection errors after facebook discontinued support for old versions of facebook messenger for android. While most of the protocol implementation was already above that version, there was a subtle change that broke fetching of sync_sequence_id, and the previously empty MQTT user agent string is now considered an old version too. See ticket #306.

 

 

Итак. Прежде всего:

 

$ sudo dnf install mercurial autoconf automake libtool

 

Затем клонируем репозиторий и пробуем запустить autogen.sh:

 

$ git clone https://github.com/jgeboski/purple-facebook.git
$ cd purple-facebook
$ ./autogen.sh

 

Сразу же натыкаемся на проблему:

 

checking for GLIB... no
configure: error: Package requirements (glib-2.0 >= 2.28.0 gio-2.0 gobject-2.0) were not met:
No package 'glib-2.0' found
No package 'gio-2.0' found
No package 'gobject-2.0' found

 

Исправляем:

 

$ sudo dnf install gtk2-devel

 

Снова пробуем autogen.sh:

 

checking for JSON... no
configure: error: Package requirements (json-glib-1.0 >= 0.14.0) were not met:
No package 'json-glib-1.0' found

 

Отметим, что json-glib-1.2.6-1.fc25.x86_64 уже присутствует в системе, и необходимо установить только json-glib-devel:

 

$ sudo dnf install json-glib-devel

 

Снова ошибка:

 

checking for PURPLE... no
configure: error: Package requirements (purple < 3) were not met: No package 'purple' found

 

Устанавливаем:

 

$ sudo dnf install libpurple-devel

 

Теперь все обязано получиться, осталось выполнить только две команды:

 

$ make
$ sudo make install

 

Итог:

 

Making install in pidgin/libpurple/protocols/facebook
make[1]: вход в каталог «/home/alex/purple-facebook/pidgin/libpurple/protocols/facebook»
make[2]: вход в каталог «/home/alex/purple-facebook/pidgin/libpurple/protocols/facebook»
make[2]: Цель «install-exec-am» не требует выполнения команд.
/usr/bin/mkdir -p '/usr/lib64/purple-2'
/bin/sh ../../../../libtool --mode=install /usr/bin/install -c libfacebook.la '/usr/lib64/purple-2'
libtool: install: /usr/bin/install -c .libs/libfacebook.so /usr/lib64/purple-2/libfacebook.so
libtool: install: /usr/bin/install -c .libs/libfacebook.lai /usr/lib64/purple-2/libfacebook.la
libtool: finish: PATH="/sbin:/bin:/usr/sbin:/usr/bin:/sbin" ldconfig -n /usr/lib64/purple-2
----------------------------------------------------------------------
Libraries have been installed in:
/usr/lib64/purple-2

 

Оставить комментарий

Добавьте ваш комментарий