×
OpenWeatherMap API: еще один погодный информер на Ruby on Rails (28 июнь 2017)

Возможно, любители и знатоки Joomla заинтересуются иным MVC-фреймворком, имя которому - Ruby on Rails?

Решено Make sure that `gem install pg -v '0.20.0'` succeeds before bundling

Больше
1 мес. 3 дн. назад #1 от evgenij
evgenij создал эту тему: Make sure that `gem install pg -v '0.20.0'` succeeds before bundling
Здравствуйте, просьба подсказать:

делаю
bundle install

, получаю
An error occurred while installing pg (0.20.0), and Bundler cannot continue.
Make sure that `gem install pg -v '0.20.0'` succeeds before bundling.

а в ответ на
$ gem install pg -v '0.20.0'

получаю, соответственно, ошибку компиляции:
------------------------

To see why this extension failed to compile, please check the mkmf.log which can be found here:

  /home/shadow/.gem/ruby/extensions/x86_64-linux/2.3.0/pg-0.20.0/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in /home/shadow/.gem/ruby/gems/pg-0.20.0 for inspection.
Results logged to /home/shadow/.gem/ruby/extensions/x86_64-linux/2.3.0/pg-0.20.0/gem_make.out


$ cat /home/shadow/.gem/ruby/extensions/x86_64-linux/2.3.0/pg-0.20.0/mkmf.log
find_executable: checking for pg_config... -------------------- no

--------------------

find_header: checking for libpq-fe.h... -------------------- no

"gcc -o conftest -I/usr/include -I/usr/include/ruby/backward -I/usr/include -I.    -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -mtune=generic -fPIC conftest.c  -L. -L/usr/lib64 -L. -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -fstack-protector -rdynamic -Wl,-export-dynamic  -m64   -lruby  -lpthread -ldl -lcrypt -lm   -lc"
checked program was:
/* begin */
1: #include "ruby.h"
2: 
3: int main(int argc, char **argv)
4: {
5:   return 0;
6: }
/* end */

"gcc -E -I/usr/include -I/usr/include/ruby/backward -I/usr/include -I.    -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -mtune=generic -fPIC  conftest.c -o conftest.i"
conftest.c:3:22: фатальная ошибка: libpq-fe.h: No such file or directory
 #include <libpq-fe.h>
                      ^
компиляция прервана.
checked program was:
/* begin */
1: #include "ruby.h"
2: 
3: #include <libpq-fe.h>
/* end */

--------------------

В чем здесь проблема?

Дождались! Fedora 26.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
1 мес. 3 дн. назад #2 от serge
serge ответил в теме Make sure that `gem install pg -v '0.20.0'` succeeds before bundling
sudo dnf install gcc gcc-c++

А я смогу! - А поглядим! - А я упрямый!
Спасибо сказали: evgenij

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
1 мес. 3 дн. назад - 1 мес. 3 дн. назад #3 от Aleksej
Aleksej ответил в теме Make sure that `gem install pg -v '0.20.0'` succeeds before bundling
sudo dnf install postgresql-server postgresql-contrib

P.S. Набросал небольшой док .
Последнее редактирование: 1 мес. 3 дн. назад от p.rishard.
Спасибо сказали: evgenij

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
1 мес. 2 дн. назад - 1 мес. 2 дн. назад #4 от evgenij
evgenij ответил в теме Make sure that `gem install pg -v '0.20.0'` succeeds before bundling
Получилось, спасибо, други. Пришлось для Rails вручную создавать БД в POstgreSQL, только потом сделал миграцию, руководствуясь сообщением Rails в браузере, но это мелочи. Я правда думал что при установке гема она сама должна создаться но, не суть.

Дождались! Fedora 26.
Последнее редактирование: 1 мес. 2 дн. назад от evgenij.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
1 мес. 2 дн. назад #5 от evgenij
evgenij ответил в теме Make sure that `gem install pg -v '0.20.0'` succeeds before bundling
Что означает, Rails: Важно: Пользователь postgres не прошел проверку подлинности (ident) ?

Дождались! Fedora 26.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
1 мес. 2 дн. назад #6 от Aleksej
Aleksej ответил в теме Make sure that `gem install pg -v '0.20.0'` succeeds before bundling
Правим файл pg_hba.conf, меняем auth-method с peer на trust.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
1 мес. 2 дн. назад #7 от serge
serge ответил в теме Make sure that `gem install pg -v '0.20.0'` succeeds before bundling

evgenij пишет: Что означает, Rails: Важно: Пользователь postgres не прошел проверку подлинности (ident) ?


Так, предваряя дальнейшие вопросы подобной тематики... :P с чем еще можем здесь столкнуться?

1. Зайдя по localhost:3000, видим сообщение Rails: База такая-то не существует. Соответственно создаем , подробнее по ссылке.

2. Зайдя по localhost:3000, видим сообщение, в котором что-то вроде:

ActiveRecord::PendingMigrationError
Migrations are pending. To resolve this issue, run: bin/rails db:migrate RAILS_ENV=development



ну, здесь понятно, проводим миграцию:

$ bin/rails db:migrate RAILS_ENV=development
== 20170618193606 CreateWeathers: migrating ===================================
-- create_table(:weathers)
   -> 0.0671s
== 20170618193606 CreateWeathers: migrated (0.0676s) ==========================

3. Если, реализуя миграцию, получаем отлуп:

$ bin/rails db:migrate RAILS_ENV=development
bash: bin/rails: Permission denied

то, соответственно, пробуем так:

$ bundle exec rake rails:update:bin

А я смогу! - А поглядим! - А я упрямый!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.