×
Ruby on Rails: постинг твитов через Twitter API (04 нояб 2017)

Практикуемся в Ruby on Rails.

Вопрос Плагин "Поддержка старых расширений (Legacy)"

Больше
6 года 5 мес. назад #1 от Arhitektorius
Arhitektorius создал эту тему: Плагин "Поддержка старых расширений (Legacy)"
Возник такой вопрос...
Если я включаю на сайте плагин Система - Поддержка старых расширений (Legacy), это каким либо образом ущемляет работу Joomla 1.5 или просто расширяет ее возможности?

Просто на моем сайте он включен, тк пару компонентов работают только в этом режиме, разницы для джумлы, с ним, или без него, я не ощущаю.
Вот просят на другом сайте поставить компонент с объявлениями, а для него надо включать этот плагин, вот и возник вопрос - какие побочные действия от него? Просто знаю, что многие Джумловоды не любят этот плагин... Почему? :blink:

Моё хобби стало моей проффесией ;)
www.BitFace.ru

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
6 года 5 мес. назад - 6 года 5 мес. назад #2 от Aleksej
Aleksej ответил в теме Re: Плагин "Поддержка старых расширений (Legacy)"
Причина нелюбви, думаю, вполне логична; на дворе вовсю joomla 1.6, и нет никакого смысла тратить время на расширение, разработчики которого не озаботились сделать нативный модуль даже для joomla v.1.5.

Попросту это говорит о том, что проект умер. В мире свободного ПО все ведь очень быстро меняется... скажем, моя Fedora обновлят те или иные пакеты не реже чем раз в два дня. И в этом, в частности, ее огромное достоинство.

Есть и иные соображения; довольно весомой мне показалась аргументация Sozzled-a , модератора форума kunena.org (подробнее по ссылке). Если вкратце - он утверждает, что kunena не тестировалась на работу в режиме legacy, и довольна велика вероятность тех или иных коллизий.

Хотя я таковых не замечал. Пока... Но следует принять во внимание, что и другие расширения joomla могут повести себя в данном контексте непредсказуемо.
Последнее редактирование: 6 года 5 мес. назад от Aleksej.
Спасибо сказали: Arhitektorius

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
6 года 4 мес. назад - 6 года 4 мес. назад #3 от Aleksej
Aleksej ответил в теме Re: Плагин "Поддержка старых расширений (Legacy)"
Здесь хотелось бы добавить одно замечание. В плане дискуссии, так сказать.

Некоторое время назад появилась у меня следующая проблема - иногда (не так чтобы уж очень часто, но...) при попытке открыть любую страничку сайта получал я следующее сообщение:

Database Error: Unable to connect to the database:Could not connect to MySQL.

Длилось это недолго, секунд тридцать максимум. Потом, без всяких усилий с моей стороны - все снова ок. Мелочь, а неприятно.

Пишу, натурально, тикет американцам (сайт на hostgator-e размещен). И в ходе диалога... получаю несколько неожиданные для меня ответы, взгляните:

Hello,

I have reviewed this issue. I investigated in greater depth your issue. It appears that you have currently 221 killed MySQL queries. 129 queries were killed because the MySQL was sleeping. The remaining 92 were all killed because the execution time was greater than 15 seconds. Any query lasting greater than 15 seconds violates the TOS. This is to ensure high quality service to other users on the same shared server. I have placed a log files in your "home/logs" folder. This log file contains all the queries killed.

Sincerely,

Pedro D.
Linux Systems Administrator
HostGator.com LLC

Hello,

This was caused by the query itself lasting longer than 15 seconds. There are so many factors involved here, that it would be hard to determine specifically what caused the query to last that long. This is commonly due to an increase in the size of the database, which causes queries to have to search through more information to complete. However, this could also be caused by a query that was written in an inefficient manner, or an increase in load on the server, which can cause the queries to take a little more time sometimes. All of your available resources such as processing power, and ram factor into how this would operate.

Cordially,

Michael Holmes
Linux Systems Administrator
HostGator.com LLC

Hello,

We do believe the issue is your Joomla installation not properly executing MySQL. Do you have any extra plugins installed? Can you provide admin access to your Joomla please?

Best Regards,
Joshua Brown
Linux Systems Administrator
HostGator.com LLC

Именно последнее сообщение заставило меня очень призадуматься; не порылась ли здесь собака именно в Legasy Mode? Собственно, скорее всего - у них сервак слегка перегружен, и в этом все дело; но одно ведь не исключает другого... На сайте у меня установлен очень недлинный ряд ортодоксальных расширений Joomla, ничего экзотичного.

Доступ к админке я не дал, нафиг оно надо... но отключил Legasy Mode - описанных проблем пока что не вижу. Посмотрим.
Последнее редактирование: 6 года 4 мес. назад от p.rishard.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
6 года 4 мес. назад #4 от Arhitektorius
Arhitektorius ответил в теме Re: Плагин "Поддержка старых расширений (Legacy)"

Aleksej пишет: но отключил Legasy Mode - описанных проблем пока что не вижу. Посмотрим.

Так значит плагин был включен...
Для чего? Он же включается для отдельных расширений?... Значит пришлось удалить и само расширение, которое он поддерживал...
Ну и может быть проблема была совсем не в плагине, неверно создать запрос к базе может ведь любое расширение... А может, например обрыв связи
Это же был единичный случай?

Моё хобби стало моей проффесией ;)
www.BitFace.ru

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
6 года 4 мес. назад - 6 года 4 мес. назад #5 от Aleksej
Aleksej ответил в теме Re: Плагин "Поддержка старых расширений (Legacy)"

Arhitektorius пишет: Это же был единичный случай?

Нет, в том-то и дело.
Пришлось удалить одно старое расширение, работавшее в режиме совместимости. Некритично.

Не хотелось мне им доступ в админку давать, как они просили. Они б, может, и раскопали, там несколько уровней поддержки... В этом отношении американцы молодцы, нашим и не снилось. Ладно, посмотрим, как оно дальше.
Последнее редактирование: 6 года 4 мес. назад от p.rishard.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
6 года 4 мес. назад #6 от Arhitektorius
Arhitektorius ответил в теме Re: Плагин "Поддержка старых расширений (Legacy)"
Хорошо, когда "некритично"
У меня, например, доска объявлений и каталог организаций работают только под Legacy... (Sobi2 и AdsManager)
Просто не смог найти для Joomla! 1.5 подходящих компонентов.
А вот на следующий сайт они ОЧЕНЬ пригодились бы, но ставить их уже не охота... :(

Моё хобби стало моей проффесией ;)
www.BitFace.ru

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
6 года 4 мес. назад #7 от Aleksej
Aleksej ответил в теме Re: Плагин "Поддержка старых расширений (Legacy)"

Arhitektorius пишет: У меня, например, доска объявлений и каталог организаций работают только под Legacy... (Sobi2 и AdsManager)...

Вам предстоит немалое удовольствие в стиле садо-мазо, когда настанет черед все это обновлять, Arhitektorius. ;)

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.