Joomla 4. Компонент K2 и форк K2ForJ4 (18 янв 2024)

Если вас, как и меня, достало выслушивать (вычитывать) бесконечные обещания разработчика K2 опубликовать версию компонента K2 под Joomla 4 (без чего невозможно реализовать апгрейд from Joomla 3 to Joomla 4) - воспользуйтесь форком K2ForJ4. Который в данный момент установлен и без каких-либо проблем работает на этом веб-сайте.

0 - Failed opening required (Joomla 4.x)

Больше
10 мес. 4 нед. назад #1 от anton
anton создал тему: 0 - Failed opening required (Joomla 4.x)
Пытаюсь переделать модуль Joomla 3 для Joomla 4, получаю ошибку на страничке сайта:
Code:
Failed opening required '/home/*******/public_html/components/com_content/helpers/' (include_path='.:/opt/php81/share/pear')

Где копать

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Dev banner 2
Больше
10 мес. 4 нед. назад - 10 мес. 4 нед. назад #2 от serge
serge ответил в теме 0 - Failed opening required (Joomla 4.x)

Где копать
В модуле, где ж еще. Найди, где использован роутер и замени (что-нибудь такое):
Code:
require_once JPATH_SITE.'/components/com_content/helpers/route.php';

на
Code:
require_once JPATH_SITE.'/components/com_content/src/Helper/RouteHelper.php';

А я смогу! - А поглядим! - А я упрямый!
Последнее редактирование: 10 мес. 4 нед. назад пользователем p.rishard. Причина: Исправлена ошибка во фрагменте кода
Спасибо сказали: anton

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
10 мес. 4 нед. назад - 10 мес. 4 нед. назад #3 от anton
anton ответил в теме 0 - Failed opening required (Joomla 4.x)

Найди, где использован роутер и замени
Вот как бы еще его найти
Последнее редактирование: 10 мес. 4 нед. назад пользователем p.rishard. Причина: Исправлена ошибка в цитировании

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
10 мес. 4 нед. назад #4 от evgenij
evgenij ответил в теме 0 - Failed opening required (Joomla 4.x)

Вот как бы еще его найти
Code:
grep -Fri 'route'

Have a lot of fun!
Спасибо сказали: anton

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
10 мес. 4 нед. назад #5 от anton
anton ответил в теме 0 - Failed opening required (Joomla 4.x)
Аааааааааааааа!..

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Работает на Kunena форум