×
Ruby on Rails: постинг твитов через Twitter API (04 нояб 2017)

Практикуемся в Ruby on Rails.

Важно Kunena 1.7 доступна, качаем

Больше
6 года 3 мес. назад - 6 года 3 мес. назад #1 от Aleksej
Aleksej создал эту тему: Kunena 1.7 доступна, качаем
29.08.2011 00:00 Kunena 1.7.0 доступна для загрузки!

Введение

Команда Kunena объявляет о выпуске Kunena 1.7.0, нативного расширения форума для J! 1.5.23, J! 1.6.6 и J! 1.7.0. Это - выпуск безопасности и замена Kunena 1.5 и 1.6, и всем пользователям рекомендуется модернизировать к Kunena 1.7.0. Резервная копия и тестирование настоятельно рекомендуются! K 1.7.0 делает все предыдущие выпуски Kunena устаревшими, и все пользователи предшествующих выпусков Kunena призваны совершить апгрейд как можно скорее.

Поддержка Kunena 1.5 прекратится спустя один месяц после выпуска K 1.7.

Чтобы достичь способности к взаимодействию со всеми J! 1.5, J! 1.6 и J! 1.7, в Kunena 1.7 уделено внимание нескольким важным задачам, перед следующим выпуском Kunena 2.0, который состоится позже в этом году. Некоторые пользователи независимых шаблонов, написанных для старых версий Kunena, обнаружат, что их шаблоны, возможно, не работают с этим последним выпуском, но изменения были необходимы, чтобы соответствовать J! 1.6/1.7 CMS. В частности, многие из независимых шаблонов, написанных для K 1.6 в его ранних стадиях вызовут проблемы. Если это - под сомнением, пожалуйста свяжитесь с авторами, ответственными за те вещи.

Все предварительно выпущенные расширения Kunena были модернизированы и должны быть отдельно установлены.

Как и всегда, Kunena 1.7.0 доступна для загрузки на странице проекта.

Highlights
  • Single package for Joomla 1.5, Joomla 1.6 and Joomla 1.7 (specifically, J! 1.5.23; J! 1.6.6 and J! 1.7.0).
  • Security Fix: JomSocial activity stream integration displays hidden topics to all users.
  • Security Fix: Only global moderators should be able to ban users.
  • Joomla 1.7 Access Level Groups support for categories (works also in J! 1.5 and J! 1.6).
  • Joomla 1.7 Access Control for component administration.
  • Joomla 1.7 Multi-Language support for Kunena menu.
  • Build-in reCAPTCHA support with some new features. Replaces J! 1.5 only CAPTCHA plugin we used before.
  • Subscriptions feature can now be configured to send emails to multiple receivers. Improves performance and helps to avoid email flooding limits.
  • Fix naming conflicts with Nooku Framework.
  • Fix a bug: Blocked users are getting subscription emails from public categories.
  • Fix a bug: Cannot log out if Community Builder integration is turned on.
  • .. and many other bug fixes.
  • Announces end-of-life for Kunena 1.6 and end of support for Kunena 1.5.

Примечание. Ряд критичных, на мой взгляд, моментов, на которые совсем нелишне обратить внимание, выделен в тексте мной.
Последнее редактирование: 6 года 3 мес. назад от Aleksej.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
5 года 11 мес. назад #2 от oleinaa
oleinaa ответил в теме Re: Kunena 1.7 доступна, качаем
Здравствуйте всем!
Обновила форум до версии 1.7.1, Джумла - 1.5.25
У некоторых пользователей стало выскакивать сообщение:
"Kunena: MooTools domready event was never fired"

С чем это может быть связано? Заранее спасибО!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
5 года 11 мес. назад #3 от Aleksej
Aleksej ответил в теме Re: Kunena 1.7 доступна, качаем

oleinaa пишет: "Kunena: MooTools domready event was never fired"
С чем это может быть связано?

Это может быть связано, опять-таки, с конфликтом js.
Попробуйте прописать перед тегом </body> следующее -
<script type='text/javascript' >jQuery.noConflict();</script>
возможно, это решит проблему.

Хотя несомненно правильнее было бы открыть firebug и детально разбираться - что именно вызывает на вашем сайте данную коллизию.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
5 года 11 мес. назад #4 от oleinaa
oleinaa ответил в теме Re: Kunena 1.7 доступна, качаем
Эту строку я уже ввела - не помогло.
Проблема возникла при переходе на новую версию. Может быть она джумле не соответствует?
Джумла у меня 1.5.25. можно ли и нужно ли как-то ее обновить до 1.7?

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
5 года 11 мес. назад #5 от Aleksej
Aleksej ответил в теме Re: Kunena 1.7 доступна, качаем

oleinaa пишет: Проблема возникла при переходе на новую версию. Может быть она джумле не соответствует?
Джумла у меня 1.5.25. можно ли и нужно ли как-то ее обновить до 1.7?

Ну, у меня-то без особых проблем работает kunena 1.7.1 в связке с Joomla 1.5.25... так что вряд ли здесь проблемы несовместимости версий. :)

Апгрейдиться до Joomla 1.7 можно, но, пожалуй, не нужно. Поддержка J1.5 и J1.7 закончится одновременно - весной. Вот тогда, как мне кажется, и в самом деле нелишне будет переползти на новый релиз Joomla с долгосрочной поддержкой.

Проблема ваша в следующем - некое расширение конфликтует с форумом. То обстоятельство, что траблы начались после обновления kunena - указывает на то, что, возможно, проблема здесь в шаблоне. Разрабы форума каждый раз при выходе нового релиза не устают повторять, что теперь, возможно, kunena окажется несовместимым с тем или иным шаблоном Joomla.

Переключитесь в дефолтный шаблон Joomla и взгляните, не исчезла ли проблема. Если не поможет - отключайте все по одному неродные расширения сайта, следя за тем, в какой именно момент проблема исчезнет.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.