Joomla 4. Компонент K2 и форк K2ForJ4 (18 янв 2024)

Если вас, как и меня, достало выслушивать (вычитывать) бесконечные обещания разработчика K2 опубликовать версию компонента K2 под Joomla 4 (без чего невозможно реализовать апгрейд from Joomla 3 to Joomla 4) - воспользуйтесь форком K2ForJ4. Который в данный момент установлен и без каких-либо проблем работает на этом веб-сайте.

An error occurred while installing nio4r (2.1.0), and Bundler cannot continue

Больше
6 года 9 мес. назад #1 от evgenij
что-то вот такое выдает:
Code:
An error occurred while installing nio4r (2.1.0), and Bundler cannot continue. Make sure that `gem install nio4r -v '2.1.0'` succeeds before bundling.

пробую инсталлить, чего просит:
Code:
$ gem install nio4r -v '2.1.0' Building native extensions. This could take a while... ERROR: Error installing nio4r: ERROR: Failed to build gem native extension.

опять не так.

Have a lot of fun!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Dev banner 3
Больше
6 года 9 мес. назад #2 от serge
лог смотри

А я смогу! - А поглядим! - А я упрямый!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
6 года 9 мес. назад #3 от Aleksej

serge пишет: лог смотри


в ответе должно быть что-то про mkmf.log.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
6 года 9 мес. назад #4 от serge
Кстати, ruby-devel установлен ли на твоей федорке?

А я смогу! - А поглядим! - А я упрямый!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
6 года 9 мес. назад #5 от evgenij

serge пишет: Кстати, ruby-devel установлен ли на твоей федорке?


да.
Code:
$ sudo dnf info ruby-dev* Последняя проверка окончания срока действия метаданных: 0:56:45 назад, Пт 22 сен 2017 21:39:49. Установленные пакеты Имя : ruby-devel Версия : 2.4.1 Выпуск : 79.fc26 Архитектура : x86_64 Размер : 283 k Источник : ruby-2.4.1-79.fc26.src.rpm Репозиторий : @System Из репозитор : fedora Краткое опис : A Ruby development environment URL : http://ruby-lang.org/ Лицензия : (Ruby or BSD) and Public Domain and MIT and CC0 and zlib and UCD Описание : Header files and libraries for building an extension library for the : Ruby or an application embedding Ruby. Имеющиеся пакеты Имя : ruby-devel Версия : 2.4.1 Выпуск : 79.fc26 Архитектура : i686 Размер : 118 k Источник : ruby-2.4.1-79.fc26.src.rpm Репозиторий : fedora Краткое опис : A Ruby development environment URL : http://ruby-lang.org/ Лицензия : (Ruby or BSD) and Public Domain and MIT and CC0 and zlib and UCD Описание : Header files and libraries for building an extension library for the : Ruby or an application embedding Ruby.


Aleksej пишет: в ответе должно быть что-то про mkmf.log.


Есть такой:
Code:
$ cat /home/rusakov/.gem/ruby/2.4.0/extensions/x86_64-linux/2.4.0/nio4r-2.1.0/mkmf.log "gcc -o conftest -I/usr/include -I/usr/include/ruby/backward -I/usr/include -I. -std=c99 conftest.c -L. -L/usr/lib64 -L. -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -fstack-protector -rdynamic -Wl,-export-dynamic -m64 -lruby -lpthread -ldl -lcrypt -lm -lc" gcc: ошибка: /usr/lib/rpm/redhat/redhat-hardened-ld: No such file or directory checked program was: /* begin */ 1: #include "ruby.h" 2: 3: int main(int argc, char **argv) 4: { 5: return 0; 6: } /* end */

Have a lot of fun!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
6 года 9 мес. назад #6 от evgenij
да, но компилятор то у меня установлен....

Have a lot of fun!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
6 года 9 мес. назад #7 от serge
Компилятор это еще не все.
:)

Code:
$ sudo dnf install redhat-rpm-config $ bundle install

Шах и мат.

А я смогу! - А поглядим! - А я упрямый!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
5 года 4 мес. назад #8 от Вебмастер
Вебмастер ответил в теме Booting Puma problem
Не уверен, что имеет отношение к Puma, но я опять сюда....
Code:
An error occurred while installing nokogiri (1.10.1), and Bundler cannot continue. Make sure that `gem install nokogiri -v '1.10.1' --source 'https://rubygems.org/'` succeeds before bundling.

Устанавливал pkg-config и так и эдак но все без толку:
Code:
gem install pkg-config -v "~> 1.1" "pkg-config" уже установлен.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
5 года 4 мес. назад #9 от evgenij
Установи
Code:
libxml2-devel libxslt-devel

или
Code:
libxml2-dev libxslt-dev

или как там они называются в твоем дистре не знаю.

Have a lot of fun!
Спасибо сказали: Вебмастер

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
5 года 1 мес. назад #10 от Вебмастер
Вебмастер ответил в теме An error occurred while installing nokogiri, and Bundler cannot continue
Короче говоря, лучше поздно чем ни когда. :sick:
Сделал уже все что советовали, но успех пришел только когда установил эти два пакета:
Code:
gcc gcc-c++

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Работает на Kunena форум