Joomla 4. Компонент K2 и форк K2ForJ4 (18 янв 2024)

Если вас, как и меня, достало выслушивать (вычитывать) бесконечные обещания разработчика K2 опубликовать версию компонента K2 под Joomla 4 (без чего невозможно реализовать апгрейд from Joomla 3 to Joomla 4) - воспользуйтесь форком K2ForJ4. Который в данный момент установлен и без каких-либо проблем работает на этом веб-сайте.

Error @rails/webpacker@5.1.1: The engine "node" is incompatible with this module

  • cool guy
  • Автор темы
  • Не в сети
  • Осваиваюсь на форуме
  • Осваиваюсь на форуме
Больше
3 года 11 мес. назад #1 от cool guy
Получил с гитхаба предупреждение о необходимости обновить одно из перечисленных в package.json (rails 6) зависимостей, но при запуске
Code:
yarn upgrade

или
Code:
yarn upgrade --latest

возвращается ошибка:
Code:
info fsevents@1.2.12: The platform "linux" is incompatible with this module. info "fsevents@1.2.12" is an optional dependency and failed compatibility check. Excluding it from installation. error @rails/webpacker@5.1.1: The engine "node" is incompatible with this module. Expected version ">=10.13.0". Got "8.17.0" error Found incompatible module.

Что делать?

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Dev banner 2
Больше
3 года 11 мес. назад #2 от evgenij
Обновите node.js.
nvm или npm в помосчь.

Have a lot of fun!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
3 года 11 мес. назад #3 от serge
Использую nmp:
Code:
npm cache clean -f npm install -g n n stable

А вообще дело вкуса, можно и из бинарников обновить. Статья в тему:
phoenixnap.com/kb/update-node-js-version

А я смогу! - А поглядим! - А я упрямый!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
3 года 11 мес. назад #4 от serge
Потом уже можно и
Code:
yarn upgrade
Последний шаг, обновление пакетов до актуальных версий, можно вот так:
Code:
npm i -g npm-check-updates && ncu -u && npm i
Отличная статья в тему.

А я смогу! - А поглядим! - А я упрямый!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
3 года 11 мес. назад #5 от evgenij
Code:
npm up node -v yarn upgrade --latest

Have a lot of fun!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Работает на Kunena форум