×
Твой новый блог на Ruby on Rails (25 дек 2020)

Не жумлой единой, как говорится. Подключайтесь. :)

Вопрос Как обновить webpacker-приложения в Rails 6?

Больше
1 год 2 нед. назад #1 от Вебмастер
Вебмастер создал тему: Как обновить webpacker-приложения в Rails 6?
Получил сообщение с гитхаба:

A new security advisory was published
We found a vulnerable dependency in repositories you have security alert access to.
Security advisory GHSA-92xj-mqp7-vmcj (high severity) affects 1 repository:


Как обновить webpacker-приложения в Rails 6?

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
1 год 2 нед. назад #2 от Aleksej
yarn upgrade @rails/webpacker --latest
:)
Спасибо сказали: Вебмастер

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
11 мес. 4 нед. назад #3 от Вебмастер
Вебмастер ответил в теме Как обновить webpacker-приложения в Rails 6?
Все получилось, спасибо.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
11 мес. 4 нед. назад #4 от serge

Все получилось, спасибо.


А быстро ты. :laugh:

yarn upgrade @rails/webpacker --latest
:)


Вот здесь интересное обсуждение об обновлении косвенных зависимостей:
github.com/yarnpkg/yarn/issues/4986
Исходя из сказанного рекомендую так:
yarn upgrade --latest

А я смогу! - А поглядим! - А я упрямый!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
4 мес. 3 нед. назад #5 от evgenij
yarn upgrade-interactive [--latest]

Have a lot of fun!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
3 мес. 20 ч. назад #6 от Вебмастер
Вебмастер ответил в теме Как обновить webpacker-приложения в Rails 6?
Вот эти непрямые зависимости, о которых в варнингах, нужно обновлять? И как.
warning @rails/webpacker > webpack > watchpack > watchpack-chokidar2 > chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
warning @rails/webpacker > webpack > watchpack > watchpack-chokidar2 > chokidar > fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
warning @rails/webpacker > webpack > node-libs-browser > url > querystring@0.2.0: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
warning @rails/webpacker > webpack > micromatch > snapdragon > source-map-resolve > resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
warning @rails/webpacker > webpack > micromatch > snapdragon > source-map-resolve > urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
warning popper.js@1.16.1: You can find the new Popper v2 at @popperjs/core, this package is dedicated to the legacy v1
warning webpack-dev-server > chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
warning webpack-dev-server > sockjs > uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
warning webpack-dev-server > webpack-log > uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
warning " > webpack-dev-server@3.11.2" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".
warning "webpack-dev-server > webpack-dev-middleware@3.7.3" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".

 

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.