Joomla 4. Компонент K2 и форк K2ForJ4 (18 янв 2024)

Если вас, как и меня, достало выслушивать (вычитывать) бесконечные обещания разработчика K2 опубликовать версию компонента K2 под Joomla 4 (без чего невозможно реализовать апгрейд from Joomla 3 to Joomla 4) - воспользуйтесь форком K2ForJ4. Который в данный момент установлен и без каких-либо проблем работает на этом веб-сайте.

LoadError: incompatible library version - msgpack.so

Больше
1 год 1 мес. назад #1 от Вебмастер
Вебмастер создал тему: LoadError: incompatible library version - msgpack.so
После перехода на rbenv с системного ruby не могу запустить рельсы, ругается на msgpack.so.
Code:
LoadError: incompatible library version - msgpack.so

Удалил Gemfile.lock, бундлил, теперь
Code:
​​​​​​​Could not find in locally installed gems

​​​​​​​Дикая головомойка, как лечить.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Dev banner 2
Больше
1 год 1 мес. назад #2 от serge
serge ответил в теме LoadError: incompatible library version - msgpack.so
Что-нибудь вроде
Code:
bundle install --system

или
Code:
bundle install --redownload

поможет.

А я смогу! - А поглядим! - А я упрямый!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
1 год 1 мес. назад #3 от Вебмастер
Вебмастер ответил в теме LoadError: incompatible library version - msgpack.so

Code:
bundle install --system
 
Вроде варнинг выдает, типа deprecated?

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
1 год 1 мес. назад #4 от serge
serge ответил в теме LoadError: incompatible library version - msgpack.so
Ну, что ж делать. Варнинг не конец света и не ошибка. Используй новый синтаксис, который предлагают (не помню сейчас). Но на данный момент еще должен работать и старый.

А я смогу! - А поглядим! - А я упрямый!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Работает на Kunena форум