×
Внимание, мошенник-работодатель (10 авг 2017)

Вниманию программистов Санкт-Петербурга, на SuperJob-е вновь активизировался Семен Григорьевич Шумейко..

Вопрос Проблема с новыми шаблонами на 3.х

Больше
3 года 5 мес. назад - 3 года 5 мес. назад #1 от АлексейК
АлексейК создал эту тему: Проблема с новыми шаблонами на 3.х
Приветствую форумчане!
Происходит у меня загадка с шаблонами Garava и Transy.
Первый бесплатный, скачен с офсайта Офсайт
Второй оттуда же, платный. Честно куплен.
В обоих шаблонах ( в отличии от других, более простых) есть папочка admin и соответственно, администрирование (настройки) шаблонов в панели.
Шаблоны устанавливаются, Гарава ровно, на нескольких браузерах, Трэнси - с причудами и перекосами.
Но самое главное - у обоих шаблонов, при попытке войти в настройки, выскакивает вот такое ругательство:





У меня - Joomla 2.5 Kunena 3.0.2. Шаблон сайта - Pj Fantome, не резиновый, выставлен на ширину в 1220 рх.
Кучка других шаблонов, работают нормально, даже какой-то от Kunena 1.6.
Под форумом, на сайте, есть временно прикрученный модуль выбора шаблонов пользователем, можно глянуть.
Территории Поиска
Как я не бился, ничего не выходит. Устанавливал шаблоны разными способами, результат... смотрите выше..
Написал на офсайт, они ничего вразумительного не ответили - типа, все шаблоны правильные, все должно работать... (читай - это теперь твои проблемы).
Есть у кого идеи?
Последнее редактирование: 3 года 5 мес. назад от p.rishard.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
3 года 5 мес. назад #2 от serge
serge ответил в теме Проблема с новыми шаблонами на 3.х

АлексейК пишет: Шаблоны устанавливаются, Гарава ровно, на нескольких браузерах, Трэнси - с причудами и перекосами.


Здравствуйте. Что значит "шаблоны устанавливаются"? вы их устанавливали через менеджер расширений, или просто распаковали в соответствующую директорию, как и устанавливают обычно шаблоны kunena?

А я смогу! - А поглядим! - А я упрямый!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
3 года 5 мес. назад - 3 года 5 мес. назад #3 от АлексейК
АлексейК ответил в теме Проблема с новыми шаблонами на 3.х
Так пардон, на скрине же видно админку с установленым шаблоном. Его миниатюра висит.
"Устанавливаются" - это значит появляются в списке шаблонов админки кунена. И соответственно, при выборе становятся шаблоном форума.
Гарава (напомню, она даже сейчас подключена, ее можно выбрать пользователю из модуля смены шаблона, который висит в футере форума), отображается почти корректно, но только в админке совершенно нет настроек, даже банальных цветов, а выскакивает сообщение (скрин).
С Трэнси - хуже. Ширина, многие позиции смещены в разных браузерах. В админке, в настройках, тоже самое, что и с Гаравой.
И если уж совсем подробно, то устанавливал шаблоны и через админку (добавить шаблон), и заливал по FTP. С одинаковым эффектом.
С более простыми шаблонами, еще раз напишу - проблем нет. Причем, шаблоны разных авторов.
ПыСы. Пробовал в качестве шаблона Джумла, подкидывать другие (с задумкой на конфликт шаблонов джумла-кунена), ничегошеньки. Все тоже самое. Ругательства на 3-ю и 37-ю строки файлов XML шаблонов.
Последнее редактирование: 3 года 5 мес. назад от АлексейК.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
3 года 5 мес. назад - 3 года 5 мес. назад #4 от Aleksej
Aleksej ответил в теме Проблема с новыми шаблонами на 3.х

АлексейК пишет: Написал на офсайт, они ничего вразумительного не ответили - типа, все шаблоны правильные, все должно работать... (читай - это теперь твои проблемы).


Простите, но я не могу поверить, что разработчик некоего расширения, тем более коммерческого, кому-либо ответил бы таким образом. Неужто они даже не попросили у вас доступа к админке и на сервер? - это обычная практика, хотя она и не оптимальна, но так практически всегда поступают, когда хотят сэкономить время. Порой предоставление полного доступа к сайту декларируется TOS и является обязательным условием саппорта.

Неужто прям-таки по-нашему и послали?

P.S. А возможно ли установить эти два шаблона без ошибок на чистую joomla/kunena где-нибудь в поддомене? при условии, что не будет установлено никаких иных расширений, не исключая и любые неродные темплейты? Попробуйте таким образом локализовать проблему.

P.P.S. И - обновляться, обновляться. По идее, никакого саппорта быть априори не может до тех самых пор, покуда и Joomla и kunena не будут у вас обновлены до актуальных версий. Kunena - обязательно; Joomla 2.5, разумеется, еще поддерживается до конца года, но я не единожды сталкивался с тем, что девелоперы концентрируют внимание на новых версиях продуктов, забывая про совместимость со старыми версиями движков и баги. Попробуйте порыть в этом направлении.
Последнее редактирование: 3 года 5 мес. назад от Aleksej.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
3 года 5 мес. назад - 3 года 5 мес. назад #5 от АлексейК
АлексейК ответил в теме Проблема с новыми шаблонами на 3.х
Писалось через форму Contact Uc, ответ - вежливая вода, и никаких конкретных предложений, увы.
Возможности установить на что-то "чистое", у меня нет. Но ваше предложение имеет, несомненно, очень рациональное звено, а именно - локализовать трабл. Происходит сие только на моем сайте или...?
всеж шаблоны 2.х не дружат с 3.х...
Обратите внимание, что на офсайте, нигде не написано что эти шаблоны "идут" к "тройке".
Может, кто-либо из форумчан, у кого Кунена 3.0.2, попробуют установить ту же бесплатную Garava с офсайта?
А про обновлять - думаю, всеж, дело не в обновлении. Шаблоны то выпущены задолго до официального релиза Кунена 3.0.2... И жуть какое у меня подозрения, что на 2.х они-то и работают.

ПыСы. На одном из форумов, посвященных проблемам Кунена, у человека с таким же "набором" (Джумла 2.5., кунена 3.х, та же Гарава тоже не открывала админку. На его вопрос так и не было ни одного ответа...
Последнее редактирование: 3 года 5 мес. назад от АлексейК.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
3 года 5 мес. назад #6 от serge
serge ответил в теме Проблема с новыми шаблонами на 3.х

АлексейК пишет: Возможности установить на что-то "чистое", у меня нет.


Да ладно. Возможности у него нету, надо же.... :P
Пожал-те вот сюда и устанавливайте чего хотите. Бесплатный Timeweb к вашим услугам, регистрация - две минуты, никаких платежей, и акк полностью и навсегда ваш. Долго ли джумлу залить? Не скажу, что безупречно работает, вот Алекс уже обламался , судя по ремаркам, но поставить Joomla 2.5, думаю, ничто не помешает. Там может быть, правда, php 5.2 только, если нужно выше - попробуйте этот хостинг , все полностью также бесплатно, качество предоставленных услуг, возможно, также классом повыше. А насчет того, что одно и то же расширение по разному способно работать в J2.5 и в J3, чистая правда. Поддерживается Joomla 2.5 то она поддерживается, а тока кому охота в мире свободного ПО под старый движок что-то кодить. Joomla 2.5 должна была закончиться уже через месяц, в марте-апреле 2014, но в последний момент поддержка продлена до конца года.

А я смогу! - А поглядим! - А я упрямый!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
3 года 5 мес. назад - 3 года 5 мес. назад #7 от АлексейК
АлексейК ответил в теме Проблема с новыми шаблонами на 3.х
Да в принципе-то все возможно. Вопрос времени. (которого вечно не хватает) :)
И писал же я уже, если проблема в шаблоне официально заявленного к версии 2.х кунены и 2.5 версии Джумла,
то с какой это радости, он заработает на более "свежих" версиях?
Ну ладно, допустим маловероятное. Сляпаю я быстренько на на новых версиях джумлы-кунены тест-сайтик, прикручу к нему шаблон, и он заработает. Ага.
Тут уж я конечно, радостно начну обновлятся (чего мне уж точно, не хочется). Опосля прикручу шаблон. А он возьми - и не заработай... Не слишком ли изощренный путь решения проблемы? По моему - да.
Если бы меня кто здесь попросил, "поставь плз, шаблончик, да погляди, заработает ли" - поверте, я бы живо откликнулся. Делов-то на 10 минут.
И вот исходя уж из "а уменя работает", (или пять раз "нет"), и можно уже принимать решения.
Ничего не усложнил? :)

ПыСы. Не в тему. (куда бы выложить). Нашел решение, когда Джумла 2.5 ставит проклятущую черточку (допустим script --- s-cript), тем самым не давая вставлять хтмл-код в модули и т.д. Без всяких бубнов с выключением редакторов, установок черных\белых списков, и писательства в кодах. (Из приведенного списка у меня ничего не "прокатывало") :dry:
Последнее редактирование: 3 года 5 мес. назад от АлексейК.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
3 года 5 мес. назад #8 от Aleksej
Aleksej ответил в теме Проблема с новыми шаблонами на 3.х

АлексейК пишет: Не слишком ли изощренный путь решения проблемы? По моему - да.


По-моему - тоже.
Так по приведенной вами ссылке черным ведь по белому написано, что два шаблона предназначены для второй kunena только:

New Kunena 2.x Template, GARAVA, is ready and available for download.
GARAVA is our second FREE Kunena 2.x template for dark background Joomla Templates, modern, all purpose, multicolor and versatile Kunena Template. Plus, you can easily customize elements from the template parameters.

We are happy to announce immediate availability of our TRANSY Kunena 2.x Template. Make your Kunena forum in tuch with your Joomla 2.5 site Template.
It is first TRANSPARENT Kunena Template released by TemplateKunena.com to utilize with Kunena 2.x. Easily integrate to your Joomla! template.


Возможно, где-то есть версии этих шаблонов под kunena 3, но я их навскидку не вижу.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
3 года 5 мес. назад #9 от АлексейК
АлексейК ответил в теме Проблема с новыми шаблонами на 3.х
Увы нету таких шаблонов. Исползал весь интернет. Новые версии Кунена продолжают комплектоваться Блю Иглом, который я уже и так изрядно трансформировал.
Вообще, создается впечатление, что "производители" шаблонов идут всегда на два шага позади разработчиков Кунена.
А новые ателье, сразу начинают с мобильных версий шаблонов. Причем, при всей их платности (25-40 $), ничего достойного (сравнимого с функционалом того же Трэнси), нету...
Все равно вопрос открыт. Ставятся ли именно эти, описанные мной шаблоны, на Кунена 3.х... :(

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
3 года 5 мес. назад #10 от evgenij
evgenij ответил в теме Проблема с новыми шаблонами на 3.х

АлексейК пишет: Все равно вопрос открыт. Ставятся ли именно эти, описанные мной шаблоны, на Кунена 3.х...


Навряд ли. Я имею в виду - навряд ли вы найдете фрилансера, который будет переписывать эти шабы. дело в том, что цена им копейки, и нет смысла заморачиваться. Но! Есть иной выход. А заче вообще заходить в админку шаблона? Я не знаю, какие свойства вы хотите менять в админке шаба, но совершенно точно, думаю, все то же самое возможно сделать просто редактируя скрипты сайта. Без админки. И для этого совсем не нужно быть программистом. Найдите в списке дополнений своего Mozilla Firefox такой бесплатный плагин, firebug называется. И все, полдела сделано. Вы можете наживую редактировать стили шаблона, просматривая тут же изменения в браузере, и если все устроит - переносить сделанные изменения в стили шаблона.

Дождались! Fedora 26.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.