Sign in

Зарегистрируйтесь, чтобы стать полноправным участником сообщества Masterpro.ws.

Ошибки kunena 1.7.1

Нет, речь не пойдет здесь о крупных уязвимостях и серьезных багах... небольшой, но довольно-таки неприятный трабл, который не так сразу и на глаза-то попадается.

Тем не менее, кое-кто из пользователей может в немалой степени охладеть к вашему форуму, если при попытке отредактировать свой профиль -

 

Редактируем профиль пользователя

 

увидит в течение нескольких секунд примерно следующее:

 

В результате редактирования

 

Интересно, правда? Вы можете поэкспериментировать сами. Наткнулся на эту проблему, открыв форум в Google Chrome; в Mozilla Firefox такого не отмечал. А IE, слава богу, не использую...

После нескольких дней глубокомысленных размышлений Matias пришел к выводу, что это все-таки баг. И решение в контексте v.1.7.1 очень несложно:

You found a bug.

Replace components/com_kunena/funcs/profile.php line 654:

$this->_app->redirect ( $return, $msg );

 

with:

 

while (@ob_end_clean());

$this->_app->redirect ( $return, $msg );

 

Это все. Подробности обсуждения - на kunena.org... варкараунд прекрасно работает. Thanks, Matias!

8 комментарии

  • Петр

    написал Петр

    Среда, 08 мая 2013 12:05

    удачно

  • Administrator

    написал Administrator

    Четверг, 01 марта 2012 11:19

    А, ну то есть ZTools не отключается у вас из админки, понятно. Интересно, а если вы выключаете шаблон - ZTools продолжает работать? И нигде в админке нет возможности отключить этот системный плагин? Не верится мне как-то.

    В любом случае, ваша проблема не имеет отношения к теме данной статьи, обозначенной как "Ошибки kunena 1.7.1". Ошибок здесь нет, разработчики kunena не устают предупреждать, что ряд шаблонов несовместим с современной версией форума. Так что, если хотите - можно продолжить обсуждение на форуме, а здесь тему закрываем.

    Но оптимальный для вас, на мой взгляд, выход - смените шаблон.

  • Максим

    написал Максим

    Четверг, 01 марта 2012 07:39

    Оказалось - форум мне валит плагин ZTools. Теперь проблема - как разобраться что в этом плагине мешает роботе Kunena? Без ZTools шаблон отказывается работать

  • Максим

    написал Максим

    Четверг, 01 марта 2012 07:08

    Вот что выяснилось... Отключил ВСЕ плагины, потом отключал ВСЕ модули и ... ничего не заработало, ДАЖЕ ПРИ ВЫКЛЮЧЕННЫХ дополнениях. Вот и дела...

  • Administrator

    написал Administrator

    Вторник, 28 февраля 2012 23:03

    Все очень несложно, и не над чем здесь ломать голову. Вам нужно попросту и не вдаваясь в детали - отключить из админки ВСЕ неродные расширения Joomla, включая и template. Оставьте только дефолтные шаблоны (и для сайта и для форума). В этот момент проблемы быть уже у вас не должно; а затем включайте все расширения поочередно и внимательно следите - в какой момент конфликт обнаружит себя вновь. Таким образом вы без проблем локализуете коллизию.

  • Максим

    написал Максим

    Вторник, 28 февраля 2012 14:11

    Дело в том что я уже ломаю голову не первый день и ничего не получается, поэтому набрался смелости обратиться к Вам, может Вы поможете хотя бы определить между чем конфликт...

  • Administrator

    написал Administrator

    Вторник, 28 февраля 2012 10:10

    JS-конфликт. Об этом и в самом деле много написано, и не только здесь. Взгляните, скажем, вот по этой ссылке - http://masterpro.ws/forum/21--kunena/719-upgrade-kunena-161-to-162#740 Логин-пароль мне без надобности, решение заключается в несложных действиях, которые вполне под силу выполнить вам самому.

  • Максим

    написал Максим

    Вторник, 28 февраля 2012 08:30

    Уважаемый Админ, знаю, что наверное уже устали от этого вопроса, но у меня не редактируется профиль в kunena (ставил разные версии). Прошу Вас помочь, сам не справлюсь. ПОЖАЛУЙСТА !!!

Оставить комментарий

Добавьте ваш комментарий